samedi 18 janvier 2014

FreetuxTV version 0.6.6

Bonjour à tous,

Eh oui vous ne rêvez pas! Une nouvelle version de FreetuxTV est disponible en version 0.6.6.

En effet, beaucoup de temps est passé depuis la dernière version (plus d'un an et demi). Ceci est dû au fait que je me suis investi dans divers projets personnels et professionnels qui font que je n'ai plus beaucoup de temps à consacrer à FreetuxTV.

Toutefois, j'ai pu constater que certaines évolutions de LibVLC rendait FreetuxTV complètement hors service. Ce qui a couté à FreetuxTV d'être retiré de Debian testing. C'est pourquoi j'ai décidé de m'y remettre un coup afin de finaliser la version que j'avais en cours, et de fournir une version fonctionnelle pour Debian.

En plus de la prise en charge de la nouvelle LibVLC, vous aurez aussi la possibilité de télécharger les logos des chaînes. En effet, le paquet Debian ne contient pas les logos pour des problèmes de droits, cette fonctionnalité permettra donc enfin de pouvoir les récupérer facilement.

Voilà, j'espère que vous apprécierez cette nouvelle version.

38 commentaires:

  1. Comment installer le bon paquet et quelles lignes de commande pour installer cette version ? Merci de cette mise à jour !

    RépondreSupprimer
    Réponses
    1. Salut André,

      Comment fais-tu pour désarchiver un Fichier *.tar.gz ? Je ne sais pas le faire.

      Nicolas DEVIENNE (ndevienne@laposte.net)

      Supprimer
    2. Salut,

      J'ai besoin des Lignes de commande pour UBUNTU 13.10

      Merci.

      Cordialement.

      Supprimer
    3. Salut,

      J'ai besoin des Lignes de commande pour UBUNTU 13.10

      Merci.

      Cordialement.

      Nicolas DEVIENNE (ndevienne@laposte.net)

      Supprimer
    4. Bonjour, la procédure de compilation se trouve ici.

      Supprimer
    5. http://code.google.com/p/freetuxtv/source/browse/trunk/README

      Supprimer
  2. Bonjour,

    Merci pour cette nouvelle mise à jour.
    Cdlt.
    Andre Arch Linux.

    RépondreSupprimer
    Réponses
    1. Salut André,

      Comment fais-tu pour désarchiver un Fichier *.tar.gz ? Je ne sais pas le faire.

      Nicolas DEVIENNE (ndevienne@laposte.net)

      Supprimer
  3. j'ai fedora et bien qu'installé (non sans quelques difficultés) je n'arrive pas à utliser freetuxtv
    [FreetuxTV] MESSAGE : Launching channel '100 %' at '2:0' -> http://www.tv-radio.com/station/100-mp3/100-mp3.m3u
    [LibVLC-Gtk] INFO : Playing http://www.tv-radio.com/station/100-mp3/100-mp3.m3u
    [LibVLC-Gtk] INFO : Using vlc options [:deinterlace=0 :access=timeshift :input-timeshift-granularity=50 :http-proxy=http://:/]
    [0x2184f88] main input error: open of `http://www.tv-radio.com/station/100-mp3/100-mp3.m3u' failed
    [0x2184f88] main input error: Votre média d'entrée ne peut être ouvert
    [0x2184f88] main input error: VLC ne peut pas ouvrir « http://www.tv-radio.com/station/100-mp3/100-mp3.m3u ». Vérifiez les messages pour plus de détails.
    [FreetuxTV] INFO : Displaying error window

    RépondreSupprimer
  4. aucune versions ne fonctionne (y compris la dernière) avec ubuntu 14.04 beta2 - vraiment dommage!!!

    RépondreSupprimer
    Réponses
    1. quel est le problème? Même avec la version 0.6.6?

      Supprimer
    2. utilise le repository ppa:freetuxtv/freetuxtv-dev - marche parfaitement.

      Supprimer
  5. Aussi 14.04 beta2 - il ne marche pas avec 0.6.5:
    An error occurred while playing channel 'France 2' : rtsp://mafreebox.freebox.fr/fbxtv_pub/stream?namespace=1&service=201&flavour=sd

    If the problem persist, you can report that the link is dead at http://database.freetuxtv.net/

    RépondreSupprimer
    Réponses
    1. Solution trouvé pour Ubuntu 14.04beta (mon comment ci-dessus), utilise le repository ppa:freetuxtv/freetuxtv-dev - ce version marche parfaitment (30 mars 14)

      Supprimer
    2. Bonjour,
      Je confirme... Suite à l'installation de Ubuntu 14.04 LTS, freetuxtv ne fonctionnait plus. J'ai mis le ppa:freetuxtv/freetuxtv-dev dans les source de ma logithèque, j'ai désinstallé et re-installé freetuxtv, et miracle... ca fonctionne à nouveau. En plus j'ai les icones des chaines... Merci et bonne chance à tous.

      Supprimer
  6. il est dommage que la version 0.6.6 ne soit pas encore dans le répertoire stable d'Ubuntu Software center

    RépondreSupprimer
  7. Bonjour,
    Je suis désolé de venir troler avec mes pbs techniques. Mais, je viens d'installer Debian7 sur virtual box (base: Ubuntu 14.10), et je ne connais rien à Debian. Je n'arrive donc pas à installer le paquet freetuxtv-0.6.6 que j'ai extrait sur mon bureau Debian. Je cherche sur le net mais je ne trouve pas de tuto simple pour pouvoir installer ce paquet manuellement via terminal. D'avance merci à vous. Au plaisir de tester Freetux !

    RépondreSupprimer
    Réponses
    1. Il n'y a pas de paquet Debian pour la version 0.6.6. Le plus simple est de compiler soit même FreetuxTV: https://code.google.com/p/freetuxtv/source/browse/trunk/README

      Supprimer
    2. Bonjour,
      Est-il possible de programmer un enregistrement? SI oui, je n'ai pas trouvé la solution dans l'interface. Par ailleurs, bravo pour ce logiciel.

      Supprimer
  8. 1) la version 0.65 en rpm est crevée, il y a une erreur quelque par
    j'ai compilé la v 0.66 et tout est ok ( mageia 4 )

    2) Serait il possible, d'ajouter les chaines via une cle tnt ?

    RépondreSupprimer
  9. Je ne vois pas les paquets deb pour la version 0.6.6 pour ubuntu 14.04 ou 13.10, seulement la version 0.6.5 dans https://launchpad.net/~freetuxtv/+archive/freetuxtv-dev (ou https://launchpad.net/~freetuxtv/+archive/freetuxtv), est-ce normal ??

    RépondreSupprimer
  10. En tout cas la version 0.6.5 (paquet) fonctionne sous ubuntu 14.04 :-) (en attendant le paquet 0.6.6 pour ubuntu 14.04)

    RépondreSupprimer
    Réponses
    1. Sur Arch Linux 64 bits, installation à partir du dépôt AUR. Il y a un Core dumped... quelle frustration, ce soft semble génial, que faire? Voici ce que ça donne:
      [FreetuxTV] INFO : Loading GtkBuilder object "dialogaddgroup" from /usr/share/freetuxtv/ui/addchannelsgroups.glade

      ** (freetuxtv:23876): CRITICAL **: gtk_builder_window_get_top_window: assertion 'GTK_IS_WINDOW(pObject)' failed

      (freetuxtv:23876): Gtk-CRITICAL **: gtk_window_set_transient_for: assertion 'GTK_IS_WINDOW (window)' failed

      (freetuxtv:23876): Gtk-CRITICAL **: gtk_window_set_position: assertion 'GTK_IS_WINDOW (window)' failed

      (freetuxtv:23876): Gtk-CRITICAL **: gtk_tree_view_get_selection: assertion 'GTK_IS_TREE_VIEW (tree_view)' failed

      (freetuxtv:23876): Gtk-CRITICAL **: gtk_tree_selection_set_mode: assertion 'GTK_IS_TREE_SELECTION (selection)' failed

      (freetuxtv:23876): GLib-GObject-WARNING **: invalid (NULL) pointer instance

      (freetuxtv:23876): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

      (freetuxtv:23876): GLib-GObject-WARNING **: invalid (NULL) pointer instance

      (freetuxtv:23876): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

      (freetuxtv:23876): GLib-GObject-WARNING **: invalid (NULL) pointer instance

      (freetuxtv:23876): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

      (freetuxtv:23876): Gtk-CRITICAL **: gtk_tree_store_clear: assertion 'GTK_IS_TREE_STORE (tree_store)' failed
      Segmentation fault (core dumped)

      Supprimer
    2. Effectivement, je me trouve dans le même cas avec la même erreur.
      Je suis sur Ubuntu 15.04 fraîchement installé et j'obtiens aussi :
      (freetuxtv:23876): Gtk-CRITICAL **: gtk_tree_store_clear: assertion 'GTK_IS_TREE_STORE (tree_store)' failed
      Segmentation fault (core dumped)

      J'espère que ce sera vite réglé :)

      Supprimer
    3. Idem sous OpenSuse 13.2, malheureusement.

      Supprimer
    4. Absolutely forgotten... Please, try to get out this software and give the development to other people. Thanks.

      Supprimer
  11. thank you, i wish make admin in freetuxtv database, so i can check submmited cchannels but i cant find register page, only see login page

    RépondreSupprimer
  12. Bonjour, après l'installation de la version 0.6.5 qui ne fonctionne pas, avec le message suivant

    "Une erreur s'est produite durant la lecture de la chaîne '2 - France 2 (auto)' : rtsp://mafreebox.freebox.fr/fbxtv_pub/stream?namespace=1&service=201

    Si le problème persiste, vous pouvez reporter que le lien est mort sur http://database.freetuxtv.net/",

    j'ai lu dans vos commentaires qu'il fallait utiliser le "repository ppa:freetuxtv/freetuxtv-dev",
    comment fait-on ? ou le trouver et ou le mettre ?
    je suis néophite et ne comprends pas bien !
    merci

    RépondreSupprimer
    Réponses
    1. http://doc.ubuntu-fr.org/freetuxtv

      tout est là mais pour moi non plus ça ne marche pas

      Supprimer
    2. Bonjour,
      Pour ceux qui sont chez le FAI BouyguesTelecom les sources en streaming MP4 et non wmv sous plug-in Verimatrix sont disponibles ici:
      http://www.bbox-actus.com/voir_news.php?article=2445

      Supprimer
  13. Bonjour, je viens de compiler FreeTuxTV sous OpenSuse, mais ça a échoué avec ce message:
    /src/gtk-date-time-picker.c:126: undefined reference to `gtk_box_new'
    D'après cette page: https://developer.gnome.org/gtk3/unstable/GtkBox.html#gtk-box-new
    je constate que la méthode gtk_box_new() n'est disponible que depuis la version 3.0 de Gtk.
    Et effectivement, en installant les devels de Gtk3, c'est passé.

    Il faudrait soir mettre à jours les dépendances requises dans le README et configure, soit revenir à l'ancienne fonction.

    RépondreSupprimer
  14. Bonjour
    Sur suse 13.2 j'ai le message en mode console suivant :
    [FreetuxTV] INFO : Compiled with GTK3
    [FreetuxTV] INFO : Compiled with LibVLC version 2.1.5
    [FreetuxTV] INFO : Compiled with libnotify version 0.7.6

    (freetuxtv:6758): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
    Trace/breakpoint trap

    Je n'arrive pas en m'en sortir, si quelqu'un a une piste. Merci.
    eric

    RépondreSupprimer
  15. Bonjour, des corrections sont a faire dans le logiciel pour être compatible avec les nouvelles version de gtk. Je n'ai plus beaucoup de temps pour m'en occuper, mais je tacherais de trouver du temps prochainement. Cordialement.

    RépondreSupprimer
    Réponses
    1. Effectivement, compiler avec gtk3 n'a finalement pas été une bonne idée.
      Déjà, il faut au préalable désinstaller les devels de gtk2 avant de compiler, sinon on se retrouve avec l'erreur rapporter par Eric.
      Mais une ceci fait, au lancement de FreetuxTv, juste après l'étape où il scan toute les chaines pendant plusieurs secondes au premier lancement, là l'application crash avec les erreurs rapporté dans le message du 13 novembre 2014.

      Alors je ne connais pas du tout gtk, mais en fuinant un peu j'ai quand même réussi à voire que c'était tous les appels à gtk_builder_get_object() de gtk_builder_object_get_object() du fichier gtk-builder-object.c qui échouaient.
      En particulier sur les éléments "treeview_channelsgroups", "button_add", "button_refresh" et "button_close".
      J'ai l'impression que c'est le fichier "/usr/local/share/freetuxtv/ui/addchannelsgroups.glade" qui est écrit en gtk2 et que gtk_builder_get_object() ne sait décoder que du gtk3.
      Je me dis que le code C ne devrait pas trop mal marché et qu'il n'y aurait que les fichiers glade à réécrire, finalement.


      Bref, j'ai finalement pris une autre direction. J'ai désinstaller les devels de gtk3 et réinstallé ceux de gtk2.
      Ensuite, dans:
      -src/freetuxtv-player-error-dialog.c
      -src/gtk-date-time-picker.c
      -src/gtk-progress-dialog.c
      j'ai remplacé "gtk_box_new(GTK_ORIENTATION_VERTICAL," par gtk_vbox_new(TRUE,".
      Après ça j'ai relancé ./ configure, sudo make install
      et j'ai pu lancé FreetuxTv avec succès, tout à l'air de fonctionner.

      Peut-être pourrais-tu sortir une version temporaire, qui reprend ces modifications et exige dans le configure les devels de gtk2 et rejette ceux de gtk3? Ou alors préciser dans le README qu'il faut les désinstaller temporairement, le temps de la compilation.


      En tous cas super soft, merci, c'est exactement ce que je cherchais.

      Supprimer
  16. bonjour
    je viens d'installer "Mageia 5" et j'ai installer freetuxtv mais ça ne fonctionne pas (j'avais déja essayer il y a 2/3 ans sur ubuntu et pareille c'est dommage !)

    mais je n'arrive pas non plus a regarder la tv via vlc donc certainement un autres soucis plus complexe ?

    et n'étant pas depuis longtemps sur "GNU-Linux" je ne comprend pas trop j'avoue
    je vais voir sur forum et doc d'ou viens mon soucis et une fois régler je donnerais des nouvelles si ça intéresse ? car j'aimerais bien ce log pour la tv et radio plutôt que de sortir la grosse artillerie : VLC

    a+

    RépondreSupprimer
  17. enfin réussi freetuxtv fonctionne grace a l'aide de ce tuto (pour ceux qui sont chez "Free")
    http://www.mageialinux-online.org/wiki/print.php?id=205

    et merci ça marche nickel

    RépondreSupprimer
  18. Shame this dont work. look good and very useful

    RépondreSupprimer
  19. Bonjour
    je suis nouvelle sous ubuntu et j'ai le même problème avec freetuxtv et le même message d'erreur dans le terminal mais je n'ai pas compris comment le résoudre. Pouvez-vous m'aider ? merci
    sylvaine

    RépondreSupprimer